Problemi

Sezione dedicata alla discussione su altre tipologie di problemi del software, quali bug e malfunzionamenti.
Rispondi
xxanthor
Messaggi: 55
Iscritto il: 05 feb 2018 09:45

Problemi

Messaggio da xxanthor »

Buongiorno a tutti

due problemi relativi alla fatturazione verso la PA (il primo lo avevo già segnalato più volte tempo fa)

1) La generazione del file XML presenta un errore nei dati del <Cessionario Committente>, per uno strano motivo a me incomprensibile quando si invia il file allo SDI viene scartato con questo errore:

Il formato dell'XML non rispetta le specifiche tecniche definite dall'Agenzia delle Entrate.
00305 1.4.1.1.2 non valido : 12345678901

l'errore è dovuto dalla presenza di quanto sotto nei dati anagrafici:

<IdFiscaleIVA>
<IdPaese>IT</IdPaese>
<IdCodice>12345678901</IdCodice>
</IdFiscaleIVA>

Nelle fatture normali è giusto che ci sia, nelle fatture verso la PA sono costretto sempre ad editare il file e cancellare quanto sopra lasciando solo:

<CodiceFiscale>97698700156</CodiceFiscale>

Fatturando spesso verso le PA è un problema, se mi dimentico di editare l'XML a mano l'invio viene scartato.


Nota: Ovviamente il problema si risolverebbe non valorizzando il campo Partita Iva nell'anagrafica ma mi chiedo se è corretto




2) Se ricevo ed inserisco due ordini diversi con lo stesso CIG ma con diversi numeri ordine e poi vado a generare un unico DDT , nel DDT non mi riporta i dati appalto e di conseguenza non li riporta nemmeno sulla fattura, sono costretto quindi ad emettere due DDT ovvero uno per ogni ordine e poi generare la fattura raggruppando i due DDT

Grazie e buona giornata

Avatar utente
lucas
Site Admin
Messaggi: 110
Iscritto il: 06 feb 2013 14:24
Località: Este (PD)
Contatta:

Re: Problemi

Messaggio da lucas »

Buongiorno, qual'è la versione di OSM?

Per il punto #1 al momento l'unica soluzione è come hai già indicato quella di omettere il campo piva nella scheda anagrafica. Per il punto #2 posso suggerirti l'utilizzo degli attributi avanzati (lo trovi vicino a duplica fattura).
Allegati
Screenshot_1.png
Screenshot_1.png (2.32 KiB) Visto 88 volte
Luca Salva'
Web developer
https://www.devcode.it

xxanthor
Messaggi: 55
Iscritto il: 05 feb 2018 09:45

Re: Problemi

Messaggio da xxanthor »

La versione è la 2.4.21.
Per ora risolvo il problema 1 togliendo la partita IVA, non appena ne ho l'occasione proverò la suluzione indicata per il punto 2.

Grazie mille

Rispondi