Errore aggiornamento da 2.4.8 a 2.4.12

Sezione dedicata ai problemi con l'installazione e l'aggiornamento del software, con discussioni sulle configurazioni di specifici server o fornitori di hosting.
mars984
Messaggi: 32
Iscritto il: 24 ago 2018 15:22

Errore aggiornamento da 2.4.8 a 2.4.12

Messaggio da mars984 »

Ciao a tutti,
sto provando ad effettuare l'aggiornamento ma mi imbatto in un errore mentre si sta aggiornando alla 2.4.10..

questo l'errore che segnala su setup.log:

Codice: Seleziona tutto

 [2020-03-26 16:18:46] Logs.EMERGENCY: Aggiornamento fallito: ALTER TABLE `co_preventivi` CHANGE `idtipointervento` `idtipointervento` INT(11) NOT NULL, ADD FOREIGN KEY (`idtipointervento`) REFERENCES `in_tipiintervento`(`idtipointervento`) []
ho già provato ad eseguire la query suggerita da dasc3er qui viewtopic.php?f=2&t=95004&start=20#p102829 ma mi ritrovo sempre con lo stesso errore e l'aggiornamento non va avanti..

avete qualche suggerimento? grazie

Avatar utente
dasc3er
Messaggi: 1088
Iscritto il: 11 lug 2016 17:41

Re: Errore aggiornamento da 2.4.8 a 2.4.12

Messaggio da dasc3er »

Ciao, il problema indicato nell'altro post è infatti diverso.
Puoi scrivere il messaggio di errore che ottiene eseguendo la query che dà il problema su PHPMyAdmin dopo che si è bloccato l'aggiornamento?

mars984
Messaggi: 32
Iscritto il: 24 ago 2018 15:22

Re: Errore aggiornamento da 2.4.8 a 2.4.12

Messaggio da mars984 »

ciao dasc3er, grazie per la risposta.. non mi ero accorto che i problemi rispetto all'altro post erano diversi, sorry..

Eseguendo la query manualmente da phpmyadmin riporta il seguente errore:

#1452 - Cannot add or update a child row: a foreign key constraint fails (`name_db`.`#sql-504_22f`, CONSTRAINT `#sql-504_22f_ibfk_1` FOREIGN KEY (`idtipointervento`) REFERENCES `in_tipiintervento` (`idtipointervento`))

Avatar utente
dasc3er
Messaggi: 1088
Iscritto il: 11 lug 2016 17:41

Re: Errore aggiornamento da 2.4.8 a 2.4.12

Messaggio da dasc3er »

Sembra quindi che ci siano dei preventivi con tipo di attività impostato in modo non corretto...

Potresti provare la seguente query e poi provare a far ripartire l'aggiornamento? Potrebbe risolvere il problema.

Codice: Seleziona tutto

UPDATE `co_preventivi` SET `idtipointervento` = 1 WHERE `idtipointervento` NOT IN (SELECT `idtipointervento` FROM `in_tipiintervento`);

mars984
Messaggi: 32
Iscritto il: 24 ago 2018 15:22

Re: Errore aggiornamento da 2.4.8 a 2.4.12

Messaggio da mars984 »

niente, ho provato ma non riesce a proseguire..

dal setup.log mi riporta sempre questo:

Codice: Seleziona tutto

[2020-03-27 18:39:08] Logs.EMERGENCY: Aggiornamento fallito: ALTER TABLE `co_promemoria` CHANGE `idtipointervento` `idtipointervento` INT(11) NOT NULL, ADD FOREIGN KEY (`idtipointervento`) REFERENCES `in_tipiintervento`(`idtipointervento`) []
{"url":"/crm/index.php?action=do_update&firstuse=false","ip":"192.168.xxx.xxx","http_method":"GET","server":"192.168.xxx.xxx","referrer":"http://192.168.xxx.xxx/crm/?force","uid":"b5a1662"}

Avatar utente
dasc3er
Messaggi: 1088
Iscritto il: 11 lug 2016 17:41

Re: Errore aggiornamento da 2.4.8 a 2.4.12

Messaggio da dasc3er »

Però il problema è cambiato!
Prova ora la seguente query:

Codice: Seleziona tutto

UPDATE `co_promemoria` SET `idtipointervento` = 1 WHERE `idtipointervento` NOT IN (SELECT `idtipointervento` FROM `in_tipiintervento`);

mars984
Messaggi: 32
Iscritto il: 24 ago 2018 15:22

Re: Errore aggiornamento da 2.4.8 a 2.4.12

Messaggio da mars984 »

Ciao,
perdonami se rispondo solo ora ma in sti giorni ho avuto un po di problemi con il computer..

anche dopo l'ultima query, l'aggiornamento non va avanti..ecco il setup.log:

Codice: Seleziona tutto

[2020-03-31 10:03:44] Logs.EMERGENCY: Aggiornamento fallito: ALTER TABLE `in_interventi_tecnici` CHANGE `idtipointervento` `idtipointervento` INT(11) NOT NULL, ADD FOREIGN KEY (`idtipointervento`) REFERENCES `in_tipiintervento`(`idtipointervento`) []
{"url":"/crm/index.php?action=do_update&firstuse=false","ip":"192.168.251.14","http_method":"GET","server":"192.168.xxx.xxx","referrer":"http://192.168.xxx.xxx/crm/?force","uid":"5d7a3f8"}

Avatar utente
dasc3er
Messaggi: 1088
Iscritto il: 11 lug 2016 17:41

Re: Errore aggiornamento da 2.4.8 a 2.4.12

Messaggio da dasc3er »

Evidentemente avete fatto un po'di danni ai tipi di interventi.

Codice: Seleziona tutto

UPDATE `in_interventi_tecnici` SET `idtipointervento` = 1 WHERE `idtipointervento` NOT IN (SELECT `idtipointervento` FROM `in_tipiintervento`);

mars984
Messaggi: 32
Iscritto il: 24 ago 2018 15:22

Re: Errore aggiornamento da 2.4.8 a 2.4.12

Messaggio da mars984 »

Nada, stavolta si è fermato al 10% e si è bloccato, se faccio un refresh sulla pagina prova a ripartire ma rimane allo 0%

Nel setup.log non segna nulla, invece nell'error.log riporta questi 2 errori:

Codice: Seleziona tutto

[2020-04-01 10:43:21] Logs.ERROR: Class 'Update\v2_4_10\Components\Descrizione' not found {"code":1,"message":"Class 'Update\\v2_4_10\\Components\\Descrizione' not found","file":"/var/www/html/crm/vendor/illuminate/database/Eloquent/Concerns/HasRelationships.php","line":487,"trace":"#0 /var/www/html/crm/vendor/filp/whoops/src/Whoops/Run.php(434): Whoops\\Run->handleError(1, 'Class 'Update\\\\v...', '/var/www/html/c...', 487)\n#1 [internal function]: Whoops\\Run->handleShutdown()\n#2 {main}"}

Codice: Seleziona tutto

[2020-04-01 10:43:21] Logs.ERROR: Fatal Error (E_ERROR): Class 'Update\v2_4_10\Components\Descrizione' not found {"code":1,"message":"Class 'Update\\v2_4_10\\Components\\Descrizione' not found","file":"/var/www/html/crm/vendor/illuminate/database/Eloquent/Concerns/HasRelationships.php","line":487,"trace":null}

Avatar utente
dasc3er
Messaggi: 1088
Iscritto il: 11 lug 2016 17:41

Re: Errore aggiornamento da 2.4.8 a 2.4.12

Messaggio da dasc3er »

Perfetto, ora il problema è causato dalla versione 2.4.12 che presentava un bug secondario nell'aggiornamento.
È sufficiente che scarichi questa cartella https://github.com/devcode-it/openstama ... te/v2_4_10 in update/v2_4_10.
Se poi fai ripartire l'aggiornamento, dovresti poter procedere.

Rispondi