Errore aggiornamento da 2.4.15 a 2.4.16 o 2.4.17

Sezione dedicata ai problemi con l'installazione e l'aggiornamento del software, con discussioni sulle configurazioni di specifici server o fornitori di hosting.
mic.cam
Messaggi: 14
Iscritto il: 17 giu 2019 16:05

Errore aggiornamento da 2.4.15 a 2.4.16 o 2.4.17

Messaggio da mic.cam »

Buongiorno,
sto riscontrando degli errori di aggiornamento dalla versione 2.4.15, sia alla ver. 2.4.16 che alla 2.4.17. Ho provato tutte le soluzioni proposte negli altri post, ma nulla da fare, l'errore persiste ed è sempre lo stesso. Allego log.
Allegati
setup.zip
(409 Byte) Scaricato 9 volte

Avatar utente
dasc3er
Messaggi: 1029
Iscritto il: 11 lug 2016 17:41

Re: Errore aggiornamento da 2.4.15 a 2.4.16 o 2.4.17

Messaggio da dasc3er »

Ciao, per favore scrivi direttamente il log nel post. La Query che causa il problema è la seguente:

Codice: Seleziona tutto

ALTER TABLE `co_righe_contratti` ADD `qta_evasa` DECIMAL(12, 4) NOT NULL
Puoi provare ad eseguirla manualmente nel database e vedere che errore viene restituito?

mic.cam
Messaggi: 14
Iscritto il: 17 giu 2019 16:05

Re: Errore aggiornamento da 2.4.15 a 2.4.16 o 2.4.17

Messaggio da mic.cam »

Scusami il ritardo nella risposta. Oggi ho riprovato l'aggiornamento in ambiente di test e sembra completarlo correttamente. Entrando, però, non visualizza nulla nelle pagine: calendario, lista ddt, interventi, etc. tutto bianco (ma rimangono i menu e i filtri delle tabelle). Non so da cosa possa dipendere. Ver. PHP 7.3.5.

Avatar utente
dasc3er
Messaggi: 1029
Iscritto il: 11 lug 2016 17:41

Re: Errore aggiornamento da 2.4.15 a 2.4.16 o 2.4.17

Messaggio da dasc3er »

Puoi controllare se ci sono dei messaggi di errore dentro la cartella logs/ oppure nei log di Apache?

mic.cam
Messaggi: 14
Iscritto il: 17 giu 2019 16:05

Re: Errore aggiornamento da 2.4.15 a 2.4.16 o 2.4.17

Messaggio da mic.cam »

Queste sono le righe presenti in php_error.log:
[29-Sep-2020 10:43:11 Europe/Rome] PHP Stack trace:
[29-Sep-2020 10:43:11 Europe/Rome] PHP 1. {main}() C:\wamp\www\gestionale\ajax.php:0
[29-Sep-2020 10:43:11 Europe/Rome] PHP 2. include_once() C:\wamp\www\gestionale\ajax.php:3
[29-Sep-2020 10:43:11 Europe/Rome] PHP 3. require_once() C:\wamp\www\gestionale\core.php:27
[29-Sep-2020 10:43:11 Europe/Rome] PHP 4. ComposerAutoloaderInitcdd58b76b4c447a733090ae8c96116f6::getLoader() C:\wamp\www\gestionale\vendor\autoload.php:7
[29-Sep-2020 10:43:11 Europe/Rome] PHP 5. composerRequirecdd58b76b4c447a733090ae8c96116f6() C:\wamp\www\gestionale\vendor\composer\autoload_real.php:60


Mentre queste sono le righe di apache_error.log:
[Tue Sep 29 10:42:32.388448 2020] [mpm_winnt:notice] [pid 12992:tid 752] AH00455: Apache/2.4.39 (Win32) PHP/7.3.5 configured -- resuming normal operations
[Tue Sep 29 10:42:32.388448 2020] [mpm_winnt:notice] [pid 12992:tid 752] AH00456: Apache Lounge VC15 Server built: Mar 28 2019 11:11:01
[Tue Sep 29 10:42:32.388448 2020] [core:notice] [pid 12992:tid 752] AH00094: Command line: 'c:\\wamp\\bin\\apache\\apache2.4.39\\bin\\httpd.exe -d C:/wamp/bin/apache/apache2.4.39'
[Tue Sep 29 10:42:32.399447 2020] [mpm_winnt:notice] [pid 12992:tid 752] AH00418: Parent: Created child process 13868
[Tue Sep 29 10:42:33.426445 2020] [mpm_winnt:notice] [pid 13868:tid 704] AH00354: Child: Starting 64 worker threads.

Avatar utente
dasc3er
Messaggi: 1029
Iscritto il: 11 lug 2016 17:41

Re: Errore aggiornamento da 2.4.15 a 2.4.16 o 2.4.17

Messaggio da dasc3er »

Ci sono delle informazioni all'interno della cartella logs/ del gestionale?
Quindi in C:\wamp\www\gestionale\logs?

mic.cam
Messaggi: 14
Iscritto il: 17 giu 2019 16:05

Re: Errore aggiornamento da 2.4.15 a 2.4.16 o 2.4.17

Messaggio da mic.cam »

No, il file di log è vuoto.

Avatar utente
dasc3er
Messaggi: 1029
Iscritto il: 11 lug 2016 17:41

Re: Errore aggiornamento da 2.4.15 a 2.4.16 o 2.4.17

Messaggio da dasc3er »

Ti posso solo chiedere di controllare se cancellando la cartella vendor/ ed estranedola dallo ZIP il problema si risolve.
Non ci sono infatti abbastanza informazioni per individuare il problema.

Che versione di PHP stai utilizzando?

mic.cam
Messaggi: 14
Iscritto il: 17 giu 2019 16:05

Re: Errore aggiornamento da 2.4.15 a 2.4.16 o 2.4.17

Messaggio da mic.cam »

Ho provato ad eliminare la cartella vendor e sostituirla con quella nello zip, ma non si risolve. Ver. PHP 7.3.5.

Allego screenshot della schermata che appare quando faccio login. Anche la rotellina in alto delle notifiche rimane in loop, come se continuasse ricerca...
Allegati
screen.png

Avatar utente
dasc3er
Messaggi: 1029
Iscritto il: 11 lug 2016 17:41

Re: Errore aggiornamento da 2.4.15 a 2.4.16 o 2.4.17

Messaggio da dasc3er »

Puoi eventualmente provare a fare un downgrade di PHP?
Per esempio alla versione 7.2? Non credo sia il problema, anche perchè solitamente l'ambiente di sviluppo prevede di utilizzare l'ultima versione disponibile (PHP 7.4 in questo caso) e non si verificano problemi del genere...

Rispondi