errore aggiornamento da 2.4.15 a 2.4.16

Sezione dedicata ai problemi con l'installazione e l'aggiornamento del software, con discussioni sulle configurazioni di specifici server o fornitori di hosting.
manu
Messaggi: 2
Iscritto il: 04 ago 2020 10:57

Re: errore aggiornamento da 2.4.15 a 2.4.16

Messaggio da manu »

Buongiorno,
credo stesso problema su installazione ex-novo. A me da errore durante l'aggiornamento alla ver 2.4.11

[2020-08-04 10:57:24] Logs.EMERGENCY: Aggiornamento fallito: ALTER TABLE `em_templates` CHANGE `id_smtp` `id_account` INT(11) NOT NULL []

PHP 7.4.8
MySQL Maria DB 10.4.13

Grazie in anticipo

Avatar utente
dasc3er
Messaggi: 1158
Iscritto il: 11 lug 2016 17:41

Re: errore aggiornamento da 2.4.15 a 2.4.16

Messaggio da dasc3er »

Ciao manu,
posso consigliarti di controllare questi post che sembrano aver risolto il porblema: viewtopic.php?f=2&t=95180&p=103513&hili ... GE#p103513 viewtopic.php?f=2&t=95114&p=103415&hili ... GE#p103415

Inoltre, il tuo problema è diverso. Ti consiglio comunque di aprire un nuovo post.

manu
Messaggi: 2
Iscritto il: 04 ago 2020 10:57

Re: errore aggiornamento da 2.4.15 a 2.4.16

Messaggio da manu »

Ops, pardon!
Ho in effetti risolto gurdando quei post ma ora ci sono errori sulle stampe.
Se vuoi puoi eliminare i miei post per fare pulizia.
Grazie mille!!

buldo
Messaggi: 28
Iscritto il: 31 lug 2019 21:47

Re: errore aggiornamento da 2.4.15 a 2.4.16

Messaggio da buldo »

Buonasera,
anche io ricevo l'errore nonostante abbia modificato il file "2_4_16.sql" come indicato, la versione di MySQL è la 5.6.47-log, può dipendere da questo?

L'errore nel log è:

Codice: Seleziona tutto

[2020-08-04 22:56:23] Logs.EMERGENCY: Aggiornamento fallito: ALTER TABLE `or_righe_ordini` ADD `id_dettaglio_fornitore` int(11) NULL DEFAULT NULL,   ADD FOREIGN KEY (`id_dettaglio_fornitore`) REFERENCES `mg_fornitore_articolo`(`id`) ON DELETE SET NULL []

Avatar utente
dasc3er
Messaggi: 1158
Iscritto il: 11 lug 2016 17:41

Re: errore aggiornamento da 2.4.15 a 2.4.16

Messaggio da dasc3er »

Ciao buldo,
Stiamo provando a risolvere il problema su diverse installazioni, e purtroppo sembra che il metodo in questo post non sia valido per tutti.
Posso consigliarti di aprire un post dedicato, così da avere un punto di contatto dedicato, e di controllare questa discussione: viewtopic.php?f=2&t=95271&start=10

Avatar utente
dasc3er
Messaggi: 1158
Iscritto il: 11 lug 2016 17:41

Re: errore aggiornamento da 2.4.15 a 2.4.16

Messaggio da dasc3er »

Annuncio la risoluzione ufficiale del problema: https://github.com/devcode-it/openstama ... ef7638e29a

Il problema si verificava con MariaDB e non MySQL. In ogni caso, è ora presente un fix relativo.
Non viene assicurato il funzionamento corretto del gestionale con DBMS diversi da MySQL.

Rispondi