[RISOLTO] Nuova installazione - errore aggiornamento alla versione 2.4.11

Sezione dedicata ai problemi con l'installazione e l'aggiornamento del software, con discussioni sulle configurazioni di specifici server o fornitori di hosting.
Rispondi
Avatar utente
lapocerchiai
Messaggi: 113
Iscritto il: 12 dic 2016 12:54
Località: Firenze
Contatta:

[RISOLTO] Nuova installazione - errore aggiornamento alla versione 2.4.11

Messaggio da lapocerchiai »

Buonasera,
sto installando il gestionale per un cliente.

Ho scaricato la versione 2.4.17.1 da GitHub, ho avviato l'installazione ma si ferma al 74% con il seguente errore:

"Errore durante l'esecuzione dell'aggiornamento alla versione 2.4.11"

Nel log della pagina, si ferma alla fase "Aggiornamento 17 di 24 (2.4.11)"
Nel file setup.log è riportato il seguente errore:
Aggiornamento fallito: ALTER TABLE `em_templates` CHANGE `id_smtp` `id_account` INT(11) NOT NULL []
Potete aiutarmi?

Grazie!
Ultima modifica di lapocerchiai il 06 nov 2020 11:35, modificato 1 volta in totale.
Lapo Cerchiai
ICT Specialist Senior
Microsoft Certified Professional
Consulenza, formazione ed assistenza informatica
Creazione siti web

Avatar utente
dasc3er
Messaggi: 1168
Iscritto il: 11 lug 2016 17:41

Re: Nuova installazione - errore aggiornamento alla versione 2.4.11

Messaggio da dasc3er »

Ciao,al riguardo ti segnalo questa discussione che dovrebbe presentare il modo per risolvere il problema: viewtopic.php?p=104275#p104275

Avatar utente
lapocerchiai
Messaggi: 113
Iscritto il: 12 dic 2016 12:54
Località: Firenze
Contatta:

Re: Nuova installazione - errore aggiornamento alla versione 2.4.11

Messaggio da lapocerchiai »

Ciao!
Innanzitutto grazie per la velocissima risposta.

Ho provato a modificare il file .sql come richiesto, ma si ferma sempre al solito punto. Stavolta con il seguente errore nel log:
Aggiornamento fallito: ALTER TABLE `em_templates` DROP `id_smtp`
Qualche altro suggerimento?

P.s. Considerato che ci potrebbero essere nuovi "clienti" che si approcciano per la prima volta a questo software, non sarebbe meglio correggere le basi di installazione onde evitare "cattiva pubblicità" ? Sarebbe un peccato...io uso il vostro programma da qualche anno e ne sono stra-contento!
Lapo Cerchiai
ICT Specialist Senior
Microsoft Certified Professional
Consulenza, formazione ed assistenza informatica
Creazione siti web

Avatar utente
dasc3er
Messaggi: 1168
Iscritto il: 11 lug 2016 17:41

Re: Nuova installazione - errore aggiornamento alla versione 2.4.11

Messaggio da dasc3er »

Visto il post qui: viewtopic.php?p=104291#p104291
Potresti indicare più nel dettaglio come hai risolto il problema?
Infatti stiamo proprio cercando di rimuovere eventuali malfunzionamenti durante gli aggiornamenti: questo sembrerebbe causato da una versione non esattamente aggiornata di MySQL oppure da un utilizzo di una branch relativa (tipo MariaDB), quindi per ora abbiamo sempre avuto problemi nel trovare e risolvere l'errore.

Avatar utente
lapocerchiai
Messaggi: 113
Iscritto il: 12 dic 2016 12:54
Località: Firenze
Contatta:

Re: Nuova installazione - errore aggiornamento alla versione 2.4.11

Messaggio da lapocerchiai »

Ciao!

Dunque, non so se ho capito bene la tua richiesta.... comunque, per quanto riguarda l'altro post (viewtopic.php?p=104291#p104291) non ho fatto niente. Ho semplicemente caricato l'aggiornamento dall'interfaccia, il sistema ha generato l'errore "rosso" (quello dello screenshot) e poi mi ha chiesto comunque l'aggiornamento del DB che è andato a buon fine.

Per quanto riguarda il problema relativo a questo post, ancora non ho risolto in nessun modo.
Il test di installazione lo sto effettuando usando XAMPP su Windows -> server MariaDB v. 10.4.14

Spero di aver risposto alla tua domanda, diversamente fammi sapere !
Lapo Cerchiai
ICT Specialist Senior
Microsoft Certified Professional
Consulenza, formazione ed assistenza informatica
Creazione siti web

Avatar utente
dasc3er
Messaggi: 1168
Iscritto il: 11 lug 2016 17:41

Re: Nuova installazione - errore aggiornamento alla versione 2.4.11

Messaggio da dasc3er »

Hai certamente risposto alla domanda, ma a questo punto non riusciamo ad individuare il problema durante l'aggiornamento (come prima quindi :roll: ).
Sembra infatti che alcune versioni di MariaDB causino problemi con la query che hai indicato all'inizio di questo post, altre no...
Rimarremo in attesa di qualcuno che riscontra il problema e non riesce a procedere, che ci aiuterà a capire se la soluzione indicata (viewtopic.php?p=104291#p104291) è corretta,
In ogni caso, il gestionale supporta ufficialmente solo MySQL: MariaDB, essendo un fork di MySQL, potrebbe causare problemi che non risolveremo con urgenza come quello in questione.

Avatar utente
lapocerchiai
Messaggi: 113
Iscritto il: 12 dic 2016 12:54
Località: Firenze
Contatta:

Re: Nuova installazione - errore aggiornamento alla versione 2.4.11

Messaggio da lapocerchiai »

OK !

Vedo allora di provare ad eseguire una nuova installazione in un ambiente che abbia MySQL e non MariaDB.

Ti faccio sapere poi l'esito.

Grazie intanto per il supporto e buona giornata!
Lapo Cerchiai
ICT Specialist Senior
Microsoft Certified Professional
Consulenza, formazione ed assistenza informatica
Creazione siti web

Avatar utente
dasc3er
Messaggi: 1168
Iscritto il: 11 lug 2016 17:41

Re: Nuova installazione - errore aggiornamento alla versione 2.4.11

Messaggio da dasc3er »

Annuncio la risoluzione ufficiale del problema: https://github.com/devcode-it/openstama ... ef7638e29a

Il problema si verificava con MariaDB e non MySQL. In ogni caso, è ora presente un fix relativo.
Non viene assicurato il funzionamento corretto del gestionale con DBMS diversi da MySQL.

Avatar utente
lapocerchiai
Messaggi: 113
Iscritto il: 12 dic 2016 12:54
Località: Firenze
Contatta:

Re: Nuova installazione - errore aggiornamento alla versione 2.4.11

Messaggio da lapocerchiai »

Grazie! Ottimo lavoro!

Metto qui di seguito il link completo a favore di chiunque altro ne abbia bisogno:

https://github.com/devcode-it/openstama ... ef7638e29a

Buon lavoro a tutti !
Lapo Cerchiai
ICT Specialist Senior
Microsoft Certified Professional
Consulenza, formazione ed assistenza informatica
Creazione siti web

Rispondi