Passaggio dalla 2.4.9 alla 2.4.19

Sezione dedicata ai problemi con l'installazione e l'aggiornamento del software, con discussioni sulle configurazioni di specifici server o fornitori di hosting.
Rispondi
paolo.mancuso
Messaggi: 23
Iscritto il: 09 gen 2019 11:49

Passaggio dalla 2.4.9 alla 2.4.19

Messaggio da paolo.mancuso »

Salve ho una installazione in produzione della 2.4.9 ci sono controindicazioni a tentare l'aggiornamento? Devo aggiornare per adeguare le nature iva. Grazie.

Avatar utente
dasc3er
Messaggi: 1158
Iscritto il: 11 lug 2016 17:41

Re: Passaggio dalla 2.4.9 alla 2.4.19

Messaggio da dasc3er »

Ciao paolo,
Non ci sono controindicazioni ufficiali per l'aggiornamento, anzi!
Ti consiglio però di testare l'aggiornamento su una installazione di test per verificare che tutto vada a buon fine: molto spesso ci vengono segnalati problemi di aggiornamento che non sono stati mai individuati prima (come puoi vedere qui nel forum :D ).

Marco72
Messaggi: 4
Iscritto il: 09 mag 2020 15:13

Re: Passaggio dalla 2.4.9 alla 2.4.19

Messaggio da Marco72 »

Buonasera a tutti, metto in coda il mio problema al precedente messaggio dato che oggi, per aggiornare i nuovi parametri per la fatturazione elettronica, ho dovuto aggiornare la versione 2.4.9 alla versione 2.4.19 di Openstamanager.
Dopo aver eseguito il backup ho iniziato ad aggiornare il database ma arrivato al 8% si e bloccato e da quel momento non mi è stato più possibile accedere al database.
errore.jpg
A quel punto ho scaricato la versione 2.4.19 ho installato e configurato il nuovo database, infine ho caricato il backup creato inizialmente ma appare il msg che richiede l'aggiornamento alla versione 2.4.10 e anche in questo caso si blocca.
In tutti e due i casi ho provato ad eseguire ?force, ma il msg e "Errore durante l'esecuzione dell'aggiornamento alla versione 2.4.10".
Allego i file presenti nella cartella logs presenti nella cartella 2.4.19.
Vi ringrazio anticipatamente
Allegati
setup 2.4.19.jpg
file cron.jpg

Avatar utente
dasc3er
Messaggi: 1158
Iscritto il: 11 lug 2016 17:41

Re: Passaggio dalla 2.4.9 alla 2.4.19

Messaggio da dasc3er »

Ciao Marco,
sembra che ci fosse un problema durante la procedura di aggiornamento: puoi provare a fare le modifiche indicate in questo commit e a fare ripartire l'aggiornamento?
https://github.com/devcode-it/openstama ... 7d444ae103

Marco72
Messaggi: 4
Iscritto il: 09 mag 2020 15:13

Re: Passaggio dalla 2.4.9 alla 2.4.19

Messaggio da Marco72 »

Grazie per la tua attenzione, premetto non sono molto pratico, però se mi dai le indicazioni per aprire la schermata dove andare a modificare la stringa indicata in rosso ci posso provare.
Grazie

Avatar utente
dasc3er
Messaggi: 1158
Iscritto il: 11 lug 2016 17:41

Re: Passaggio dalla 2.4.9 alla 2.4.19

Messaggio da dasc3er »

Nel file update/2_4_10.php, devi modificare la riga 73 da

Codice: Seleziona tutto

    $query = 'SELECT * FROM in_tipiintervento';
a

Codice: Seleziona tutto

    $query = 'SELECT in_tipiintervento.*, in_tipiintervento.idtipointervento AS id FROM in_tipiintervento';

Marco72
Messaggi: 4
Iscritto il: 09 mag 2020 15:13

Re: Passaggio dalla 2.4.9 alla 2.4.19

Messaggio da Marco72 »

Ho provato a modificare la stringa che mi hai inviato ma il problema persiste, o eliminato il database creato in precedenza, ho creato e configurato il nuovo database versione 2.4.19 e tutto e filato liscio la nuova versione si avvia, ho caricato il backup creato dalla versione 2.4.9 ma dopo averlo caricato mi chiede di eseguire l'aggiornamento, confermo la richiesta ma si blocca all' 8%.
il file setup presente nella cartella LOGS scrive cosi

[2020-12-14 12:23:19] Logs.EMERGENCY: SQLSTATE[42S02]: Base table or view not found: 1146 Table 'openstamanager2.4.19.dt_automezzi' doesn't exist []
{"url":"/openstamanager-2.4.19/index.php?action=do_update&firstuse=false","ip":"::1","http_method":"GET","server":"localhost","referrer":"http://localhost/openstamanager-2.4.19/ ... ":"fcb8059"}
Ultima modifica di Marco72 il 14 dic 2020 17:13, modificato 1 volta in totale.

Marco72
Messaggi: 4
Iscritto il: 09 mag 2020 15:13

Re: Passaggio dalla 2.4.9 alla 2.4.19

Messaggio da Marco72 »

Navigando nella cartella update di openstamanager 2.4.19 noto che sono presenti 2 cartelle denominate v2.4.10 e v2.4.17 che contengono i seguenti file:
Allegati
cartella v2_4_17.jpg
Cartella v2_4_10.jpg

paolo.mancuso
Messaggi: 23
Iscritto il: 09 gen 2019 11:49

Re: Passaggio dalla 2.4.9 alla 2.4.19

Messaggio da paolo.mancuso »

Sto provando ad aggiornare su una replica di test, per evitare di spaccare la produzione. Dalla 2.4.9 alla 2.4.19 non funziona.
Ci sono delle "function" che non esistendo prima della 2.4.16 non possono funzionare.
Ho deciso quindi di procedere per step quindi di aggiornare passo passo di versione in versione.
Detto ciò, dalla 2.4.9 alla 2.4.10 l'aggiornamento va a buon fine, nel menù Aggiornamenti però viene fuori il seguente messaggio di warning:
Attenzione! Ci sono delle tabelle non previste nella versione standard del gestionale: co_tipi_scadenze, zz_user_sedi.

@Dasc3er si tratta di un problema o posso passare ad aggiornare alla 2.4.11?
Come è possibile risolvere?
Grazie.

Rispondi