Errori aggiornamento da 2.4.13 a 2.4.20

Sezione dedicata ai problemi con l'installazione e l'aggiornamento del software, con discussioni sulle configurazioni di specifici server o fornitori di hosting.
Rispondi
lucapsg
Messaggi: 18
Iscritto il: 15 feb 2017 12:18

Errori aggiornamento da 2.4.13 a 2.4.20

Messaggio da lucapsg »

Buongiorno a tutti,
la mia installazione di OSM è “come mamma l’ha fatta”: nessuna personalizzazione software né alterazioni alla struttura del DB. Ambiente PHP 7.3, upload_max_filesize = 32MB, post_max_size = 32MB e MySQL 5.6.45.

Verificato questo, avvio l'aggiornamento da interfaccia web e poco dopo il caricamento del file zip compare questo errore:

Codice: Seleziona tutto

Si è verificato un'errore [uid: 59735df]. Se il problema persiste siete pregati di chiedere assistenza tramite il forum apposito (https://forum.openstamanager.com/).
Fatal Error (E_ERROR): Call to undefined function string_starts_with()
err1.png

Clicco su Dashboard, mi viene proposto l’aggiornamento del database, lo eseguo e termina senza avvisi.

Eseguo nuovamente il login, torno nella pagina Aggiornamento e verifico l’integrità dell’installazione.
Dal Controllo file risulta un “File con integrità errata”: /modules/listini/bulk.php
err2.png
Indago e vedo che nel server manca completamente la cartella /modules/listini. Nel file zip dell’installazione c’è e c’era anche nell’installazione precedente ma con un contenuto diverso.
Copio a mano la nuova cartella e relativo contenuto ed eseguo nuovamente Controllo file: “Nessun file con problemi di integrità”. Problema risolto.

Al Controllo database emergono invece tre conflitti in altrettante tabelle:
  • co_tipidocumento
    Colonna Conflitto
    descrizione {"type":{"current":"varchar(125)","expected":"varchar(100)"}}
  • em_print_template
    Foreign keys Conflitto
    em_print_template_ibfk_3 {"current":null,"expected":{"column":"id_template","referenced_table":"em_templates","referenced_column":"id"}}
  • in_righe_interventi
    Colonna Conflitto
    descrizione {"type":{"current":"text","expected":"varchar(255)"},"null":{"current":"YES","expected":"NO"}}
err3.png

Fermo restando il dubbio sulla causa del primo errore, come posso fare per risolvere quello relativo al database?
Grazie in anticipo.

lucapsg
Messaggi: 18
Iscritto il: 15 feb 2017 12:18

Re: Errori aggiornamento da 2.4.13 a 2.4.20

Messaggio da lucapsg »

Update...:
Dato che sul sito viene ancora proposto il download della 2.4.19 ho eseguito una installazione pulita e aggiornato il solo database.

Al termine il Controllo database ha evidenziato lo stesso conflitto già segnalato in questo post che ho risolto come suggerito da @dasc3er: viewtopic.php?f=10&t=95416&p=104399&hil ... te#p104399

In attesa di informazioni/soluzioni per l'aggiornamento alla 2.4.20 resto alla 2.4.19.
Grazie e saluti.

Rispondi