Errore installazione 2.4.22

Sezione dedicata ai problemi con l'installazione e l'aggiornamento del software, con discussioni sulle configurazioni di specifici server o fornitori di hosting.
Rispondi
Ghennet
Messaggi: 3
Iscritto il: 27 apr 2021 12:14

Errore installazione 2.4.22

Messaggio da Ghennet »

Buongiorno a tutti ho diversi problemi durante l'installazione della 2.4.22 su un server Plesk, php 7, e MariaDB

Durante l'installazione mi va in Crash alla seguente riga 188 del file 2_4_22.sql, ho risolto modificandola così
ALTER TABLE `or_ordini` ADD `codice_commessa` VARCHAR(100) NULL;

allo step successivo dove configuro l'azienda invece mi presenta questo errore
"Si è verificato un'errore [uid: 20a2082]."
e nel file di LOG trovo la mancanza del campo
Unknown column 'updated_at' in 'field list' ...

Lo stesso campo che generava l'errore nella ALTER TABLE di sopra...


Cosa mi sfugge ? grazie a tutti e buona giornata

Avatar utente
dasc3er
Messaggi: 1210
Iscritto il: 11 lug 2016 17:41

Re: Errore installazione 2.4.22

Messaggio da dasc3er »

Ciao,
credo che il problema sia l'utilizzo di MariaDB. Il gestionale supporta MySQL con versione >= 5.7, per quanto riguarda MariaDB non è supportato ufficialmente ma consiglio di usare una delle versioni più recenti.

Ghennet
Messaggi: 3
Iscritto il: 27 apr 2021 12:14

Re: Errore installazione 2.4.22

Messaggio da Ghennet »

Grazie della riposta, è che usando sul server di produzione plesk per gestire i domini/abbonamenti/ecc MariaDB è installato di 'ufficio'.

La versione che ho su ora è la 5.5.68

Mi basterebbe sapere la tabella in cui cerca quel campo per inserirlo ...

Avatar utente
dasc3er
Messaggi: 1210
Iscritto il: 11 lug 2016 17:41

Re: Errore installazione 2.4.22

Messaggio da dasc3er »

Purtroppo il campo updated_at è necessario in tutte le tabelle...
Per favore, cerca di rispettare i requisiti minimi del software. Puoi risolvere il problema aggiornando MySQL e reinstallando il gestionale da zero.

Ghennet
Messaggi: 3
Iscritto il: 27 apr 2021 12:14

Re: Errore installazione 2.4.22

Messaggio da Ghennet »

dasc3er ha scritto: 29 apr 2021 13:51 Purtroppo il campo updated_at è necessario in tutte le tabelle...
Oh, cavoli, dovrei capire in quale tabella non è riuscito a crearlo ... e visto il numero la vedo molto dura...
Puoi risolvere il problema aggiornando MySQL e reinstallando il gestionale da zero.
Il punto è che dovrei installare mysql al posto di MariaDB e siccome è un server di produzione, credo che, rinuncerò ... :(

Avatar utente
dasc3er
Messaggi: 1210
Iscritto il: 11 lug 2016 17:41

Re: Errore installazione 2.4.22

Messaggio da dasc3er »

Purtroppo non abbiamo altro modo, alcune funzionalità dei software su cui il gestionale funziona sono integrate sollo in versioni più recenti. Non dovrebbe essere molto complesso aggiornare la versione di base di MySQL, anche in un server di produzione, a patto che non sia un server con altro software con specifiche dependence.

Rispondi